Issue processing payments via the QikServe Payment Services
Incident Report for QikServe
Resolved
No further issues noted following monitoring.
Posted Nov 17, 2022 - 17:27 GMT
Monitoring
This issue has now been resolved but we continue to monitor the health of the service.

We would like to apologise for the inconvenience caused. Please let us know if there’s anything else we can help you with by contacting us at support@qikserve.com
Posted Nov 17, 2022 - 16:25 GMT
Investigating
We are currently experiencing issues processing payments via the QikServe Payment Services. We are actively investigating the issue and will update this page with more information as this becomes available.

We apologise for the inconvenience this causes.
Posted Nov 17, 2022 - 16:00 GMT
This incident affected: Integrations (Payment Integrations).