Issue loading menus on US Kiosks

Incident Report for QikServe

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 17:30 GMT

Monitoring

A mitigation has been implemented, and we are seeing services return to normal. We will continue monitoring the situation.
Posted Jan 30, 2026 - 16:38 GMT

Identified

We have identified the issue as relating to load, and are employing methods to mitigate.
Posted Jan 30, 2026 - 15:55 GMT

Update

We are continuing to investigate this issue.
Posted Jan 30, 2026 - 15:02 GMT

Investigating

We have been made aware that it is taking longer to load menus on kiosks using the US server. Transactions are not impacted, but there may be challenges updating existing menus.

We are investigating and will update when we have more information
Posted Jan 30, 2026 - 13:42 GMT
This incident affected: Guest Facing Applications- US platform (Kiosk- US).