Kiosk Service Degraded

Incident Report for QikServe

Resolved

Kiosks are operating with consistent stability and the reported situation is resolved. A incident report including further detail will be made available.
Posted Aug 13, 2025 - 00:10 BST

Monitoring

Kiosk statuses have been reviewed and we are showing kiosks across the estate are operating as expected. QikServe is continuing to monitor for any impacted devices while the incident is presenting as resolved.
Posted Aug 12, 2025 - 22:29 BST

Investigating

QikServe is investigating a reported issue where some kiosks are not loading content. QikServe, is actively reviewing the situation to identify the root cause and implement a resolution. We will provide updates as more information becomes available.
Posted Aug 12, 2025 - 20:34 BST
This incident affected: Guest Facing Applications- US platform (Kiosk- US).