Payment issue

Incident Report for QikServe

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 16:43 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2026 - 14:38 BST

Investigating

We are aware of an issue affecting payments where users may encounter the error message "Venue Not Found" during the payment process.

Our engineering team is actively investigating the issue and working to identify the root cause. We understand the impact this may have and are treating this as a high priority.

We will provide further updates as soon as more information becomes available
Posted Aug 19, 2026 - 13:09 BST
This incident affected: Common Services - EMEA platform (Store Dashboard - https://manage.withqikserve.com/).