Kiosk Service Degraded

Incident Report for QikServe

Resolved

Kiosks are operating with consistent stability and the reported situation is resolved. A incident report including further detail will be made available.
Posted Jul 29, 2025 - 00:47 BST

Monitoring

Kiosk services are now successfully logging and returning the expected responses on our platform. QikServe has applied a resolution and is continuing to monitor the system to ensure ongoing stability.
Posted Jul 28, 2025 - 23:18 BST

Investigating

QikServe is investigating reports where a limited amount of kiosks experiencing communications issues. QikServe, is actively reviewing the situation to identify the root cause and implement a resolution. We will provide updates as more information becomes available.
Posted Jul 28, 2025 - 22:29 BST
This incident affected: Guest Facing Applications- US platform (Kiosk- US).