Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 18 days ago. Feb 24, 2025 - 11:00 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted 1 month ago. Feb 10, 2025 - 15:41 GMT
Scheduled
QikServe will be undergoing scheduled maintenance of US Kiosk Services from 11:00 AM to 1:00 PM UTC. During this maintenance window there will be a maximum downtime of 1 hour where kiosk services will not be available. Following the maintenance, kiosk services will resume immediately.
We have taken every appropriate measure to minimise the duration and impact of this maintenance and do not foresee any issues as a result.
If you have questions or issues, please contact the team at support@qikserve.com
Posted 1 month ago. Feb 03, 2025 - 15:40 GMT
This scheduled maintenance affected: Guest Facing Applications- US platform (Kiosk- US).